Wikia

Magic Lantern Firmware Wiki

Release 0.1.6

Talk1
319pages on
this wiki

Release 0.1.6 Edit

After a month of development and testing, release 0.1.6 is finally ready! Some of the new features:

AudioMenu
New audio menu
  • Custom cropmarks bitmap file
  • Live histogram while recording
  • Time remaining estimate indicator
  • Automated Focus pulls
  • Focus stacking
  • HDR exposure bracketing
  • Lens data (hyperfocal distance, DOF, etc)
  • Cleaner, multi-level menus that timeout automatically
  • Audio monitoring can be turned off during clip review
  • Internal mic can be used (must enable audio.mic-power=1 in config)
  • Output audio volume control
  • Configuration file can be saved to magiclantern.cfg

Release notes Edit

Zebra and cropmarks
Zebras, histogram and custom cropmarks
AutopilotAdded by Autopilot

General Edit

  • Unchipped ("Chinese") batteries still do not work
  • First second of audio may be at wrong levels
  • Lens info only works with modern Canon lenses

Bracketing Edit

  • Bracketing does not work in Manual mode. You must use either Av or Tv mode.
  • Bracketing must be done in Liveview Mode (will lock up the camera, remove battery to reset)
  • The camera will attempt to focus between each shot; use manual focus mode instead
Focus screen
Depth of field info
AutopilotAdded by Autopilot

Focus pulling / stacking Edit

  • Only works in Liveview Mode
  • Occasionally locks up camera (remove battery to reset)

HDMI output Edit

  • Zebra and cropmarks will not display correctly
  • Histogram may be calculated incorrectly
  • Only outputs 480p while recording (quicktime file is still 1080p)



Support the project! Edit

Autopilot-onset

Thanks to your help, we have covered all our funding needs for now.

Please consider donating to EFF for us, because they do a great job in defending your digital rights, including the right to run third party software on your own devices!

Download link Edit

If you have any problems, please report them on the issue tracker. If you are interested in building your own version, you can download sources under the terms of the GPL.

Please note that this firmware requires Canon firmware 1.1.0 ONLY. If you have upgraded to 1.2.4, please be aware that this release will not work at all with it. The next release will have support for 1.2.4 or the follow-on release with the new video modes.

Good luck!

Around Wikia's network

Random Wiki