Fandom

Magic Lantern Firmware Wiki

Magic Lantern for Canon 5D MkII firmware

328pages on
this wiki
Add New Page
Talk0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.

Thanks guys. I have now installed the 2.1.1 firmware but can't seem to find the correct Magic Lantern firmware for my 5D MkII


Can anybody please tell me which version I need and post a link to the download if possible.

Thanks for the info on downgrading from 2.1.2 to 2.1.1

Does anyone have a link to the 2.1.1 firmware?

Hi,

I'm new to the Canon 5D MkII and Magic Lantern and my 5D MkII has 2.1.2 Firmware.

Is there a Magic Lantern update for 2.1.2 or anyway I can downgrade my camera fiormware to 2.1.1 so I can use Magic Lantern?

I have exhausted all the online searches I can find and any help on this would be greatly appreciated.

If do you need the 2.1.1 firmware send email to hr82psc@yahoo.com! [[Category:Downgrading is simple just follow the instructions for to upgrade your firmware. The 5DMK2 will allow you to downgrade from 2.1.2 > 2.1.1]]

Also on Fandom

Random Wiki